Hi Andreas

Stephan, can you confirm this, it's really a bug!
Please try the sample foo package from Andreas.

Behalf Of Andreas Reuleaux
> Sent: Saturday, July 30, 2005 12:00 PM
> To: zope3-dev@zope.org
> Subject: Re: [Zope3-dev] Zope 3 Bug Day Summary, 421 not solved
> First of all thank you for closing all the bugs.
> The bug that I had reported previously, 421
> was resolved by Stephan Richter with the words
>     Status: Pending => Rejected
>     I cannot reproduce this problem and honestly it does not make much
>     sense. Nothing about missing value is different between Text and
>     TextLine.
> I am still getting this bug though.
> So before discussing why this bug occurs or if this makes sense, I
> would like some confirmation of this list that indeed this bug still
> occurs.
> I had taken the effort to prepare a really small example package foo
> that demonstrates the problem, so the steps to reproduce this
> bug should be really simple:
>   * download http://www.zope.org/Collectors/Zope3-dev/421/foo.tgz
>     and unpack it in your zope instance dir
>   * add a foo-configure.zcml file in your etc/package-includes
>     with a line: <include package="foo"/>
>   * then, after restarting z3 try to add a Foo object
>     somewhere in your tree  
> The result I get is some garbage html in the auto-generated add
> form (I had also put a screenshot of that garbage in the foo.tgz
> package)
> In the meanwhile I have tried this foo examples in different
> environments:
> * I get this bug when using Mozilla Firefox 1.0.4 from
>   Debian stable (sarge)
> * I also get it with Mozilla Firefox 1.0.6 from Debian
>   unstable (sid)
> * I don't get this bug with konqueror 3.3.2 from Debian stable
>   (sarge)
> So it seems the auto-generated html of the add form and firefox'
> way of rendering it don't work well together, and my guess is
> that Stephan has just been trying to reproduce it in
> a different environment.
> Still, in my opinion the html produced should work in a fairly
> recent version of Firefox.
> Again: Just some confirmation of the reported behaviour, please.
> Thanks, Andreas 

I think you found a important bug. The addform renders only the first
field "bar" correct. The second field "boom" (TextArea) contains the
raw HTML code of the rest of the add form as it's input.

The hole third field is contained as raw HTML in the second TextArea
like described above. 

Uhhh, I don't know what's going on here. The code of the package looks 
Ok to me for the first visit. 

I tried this with WinXP and ie on the newest trunk version 37590

Roger Ineichen

Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to