[Moving discussion to zope3-dev from zope3-checkins.]
On 11/9/05, Stephan Richter <[EMAIL PROTECTED]> wrote:
> Could we name the package something else, like "zipresource" or so? Resource
> is a somewhat loaded word in Zope 3 already.
I'm open to suggestions. I don't like "zipresource" since this is
intended to work with any alternate import loaders that support the
get_data() protocol described in PEP 302. Bob Ippolito's
pkg_resources package deals with the same issues, but I think we want
to provide this alternate API since we want to support ordinary paths
Perhaps "zope.filereference"? I plan to add support for directories
as well, but since that's mostly to gain ways to deal with collections
of files, "zope.filereference" would still be reasonable.
Fred L. Drake, Jr. <fdrake at gmail.com>
"Society attacks early, when the individual is helpless." --B.F. Skinner
Zope3-dev mailing list