On 2/14/06, Philipp von Weitershausen <[EMAIL PROTECTED]> wrote:
> The naming of the component already gives it away as a factory. To me that's
> enough naming.
I think I agree. This to me makes sense. If it were nameless (are
there nameless utilities) you could then get off with just <utility
component=".alias.sydneyFactory" /> which is then the on/off switch we
mentioned earlier. And an adapter should be registered the same way
<adapter component=".alias.FidgetAdapter" /> and what it adapts
between should be a part of the python-code with an adapts(ISomething)
declaration, just like implements(ISomethingelse), which I think you
suggested in your "ZCML does doo much" blog, right?
Lennart Regebro, Nuxeo http://www.nuxeo.com/
CPS Content Management http://www.cps-project.org/
Zope3-dev mailing list