Andreas Jung wrote:


--On 16. August 2006 08:36:55 -0400 Benji York <[EMAIL PROTECTED]> wrote:


Jodok Batlogg wrote:

Log message for revision 69426:
 Initial import from Lovely Systems repository

Changed:
 A   lovely.rating/

This package appears to depend on GPLed software (schooltool,
specifically:
http://svn.zope.org/lovely.rating/trunk/src/lovely/rating/interfaces.py?r
ev=69429&view=markup)

I'm not sure it's appropriate to put it in the zope.org repo.


huh? The contributor agreement says nothing about external dependencies. As look as the checked-in code is ZPL, your software can depend on any other external package (independent of its license).

This is technically true, but there are a couple of issues. First, because this code depends on a GPLed component, so it not useful to people who require their projects to be ZPL. Second, it is a departure from the status quo, such decisions should be made by the ZF.
--
Benji York
Senior Software Engineer
Zope Corporation
_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to