On 8/19/06, Andreas Jung <[EMAIL PROTECTED]> wrote:
Benji,

when running the Zope 2.10b2 unittests I see the following tests failing
(however this is not a blocker for the 2.10b2 release):

Failure in test test_strip_linebreaks_from_textarea (zope.testbrowser.tests)
Failed doctest test for
zope.testbrowser.tests.test_strip_linebreaks_from_textarea
  File
"/develop/sandboxes/Zope-2.10/2.10.0b2/lib/python/zope/testbrowser/tests.py",
line 222, in test_strip_linebreaks_from_textarea

----------------------------------------------------------------------
File
"/develop/sandboxes/Zope-2.10/2.10.0b2/lib/python/zope/testbrowser/tests.py",
line 245, in zope.testbrowser.tests.test_strip_linebreaks_from_textarea
Failed example:
    browser.getControl(name='textarea').value
Expected:
    'Foo\n'
Got:
    '\nFoo\n'
----------------------------------------------------------------------
File
"/develop/sandboxes/Zope-2.10/2.10.0b2/lib/python/zope/testbrowser/tests.py",
line 263, in zope.testbrowser.tests.test_strip_linebreaks_from_textarea
Failed example:
    browser.getControl(name='textarea').value
Expected:
    '\nFoo\n'
Got:
    '\n\nFoo\n'


This is already fixed according to:
http://www.zope.org/Collectors/Zope3-dev/645

The fix is in 'ClientForm.py', this file is *not* set as an
svn:external in Zope 2.
Just setting this as svn:external to Zope 3.3 will fix this problem,
otherwise update this module.

Regards,
Baiju M
_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to