Marius Gedminas wrote:
BTW passing interfaces to provideAdapter/<adapts> is out of fashion.
This stuff is getting almost perl-ish in it's "there's many ways to do
it, pick the style you like" nature..
prefer using zope.component.adapts and zope.interface.implements (or
zope.component.adapter and zope.interface.implementer, when my adapter
is a function rather than a class).
I often register the same adapter factory for several different types or
objects / interfaces. How would I do that with your favoured spelling?
Simplistix - Content Management, Zope & Python Consulting
Zope3-dev mailing list