Christian Theune wrote:
I noticed that the buildbots have not run a successfull Zope 3 trunk
build since March 25. :(

The only builder that is configured to run the trunk and is currently on-line is zc-buildbot, and it would appear to be running the tests with every trunk check-in.

OTOH, the 3.2, and 3.3 branches are broken and have been for quite some time.

Sidebar: when trying to kick off a run for those two branches those two builders started exhibiting assertion errors, I'm looking into why that is.

Most of the clients are broken.

The single Windows slave that is "purple" is a result of bugs in twisted/buildbot. Hopefully newer versions don't have these problems. (We currently run 0.6.6, 0.7.5 is the latest). I don't have time to fight with upgrading at the moment.

Two others are off-line, see the nagging section below. ;)

The one at ZC is good but hasn't been
run for quite a while.

zc-buildout appears to run the trunk tests with every check-in. Is that the one you are referring to? The 3.2 and 3.3 tests failed the last time they were manually run. I don't think any changes have been made to those branches since, therefore not further runs have been triggered.

Some of the rules that detect changes in the
branches seem unreliable.

Can you give an example?

I propose to start make the clients do nightly builds.

That's fine with me.  I can get that configured pretty easily.

Also, do we have
someone who is the official 'client nagging guy' to remind people when
their buildbot clients die?

I'll be glad to nag anyone, but don't consider it a privilege available to only a few. The slave names are pretty clear (a couple could be clearer), so anyone can get a good nag in once and a while.
Benji York
Senior Software Engineer
Zope Corporation
Zope3-dev mailing list

Reply via email to