On Apr 19, 2007, at 6:43 AM, Christian Theune wrote:

Am Donnerstag, den 19.04.2007, 05:59 -0400 schrieb [EMAIL PROTECTED]:
The Buildbot has detected a failed build of Zope3 trunk 2.4 Linux zc-buildbot.

Buildbot URL: http://buildbot.zope.org/

Build Reason: changes
Build Source Stamp: 124
Blamelist: ctheune,schwendinger,zagy

:(

I see those errors on Zagy's Mac OS X machine and a couple of Linuxes.

I also see the test runner crash with

Total: 9615 tests, 1 failures, 0 errors
Error in atexit._run_exitfuncs:
Traceback (most recent call last):
   File "/sw/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
     func(*targs, **kargs)
File "/sw/lib/python2.4/logging/__init__.py", line 1332, in shutdown
     h.flush()
   File "/sw/lib/python2.4/logging/__init__.py", line 718, in flush
     self.stream.flush()
ValueError: I/O operation on closed file
Error in sys.exitfunc:
Traceback (most recent call last):
   File "/sw/lib/python2.4/atexit.py", line 24, in _run_exitfuncs
     func(*targs, **kargs)
File "/sw/lib/python2.4/logging/__init__.py", line 1332, in shutdown
     h.flush()
   File "/sw/lib/python2.4/logging/__init__.py", line 718, in flush
     self.stream.flush()
ValueError: I/O operation on closed file

Every now and then.

This is due to a bug in the logging module. I'm not sure which test runner this is, but when this happens to me, I either ignore it or add an os._exit call to the end of my test runner. I think I heard that this was fixed in Python 2.5. :/

Jim

--
Jim Fulton                      mailto:[EMAIL PROTECTED]                Python 
Powered!
CTO                             (540) 361-1714                  
http://www.python.org
Zope Corporation        http://www.zope.com             http://www.zope.org



_______________________________________________
Zope3-dev mailing list
Zope3-dev@zope.org
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to