On May 19, 2007, at 12:22 PM, Paul Carduner wrote:

Upon a fresh checkout and make of the 3.3.0 tag of Zope3, I get the
following error:

Installed /home/pcardune/work/cando-2006/SchoolTool/Zope3/src/ zc.i18n-0.6.1dev_r72454-py2.4.egg
error: Installed distribution zc.catalog 1.2dev-r74943 conflicts with
requirement zc.catalog==0.1.1

I noticed that it installed the later zc.catalog version with hurry.query

Installed /home/pcardune/work/cando-2006/SchoolTool/Zope3/src/ hurry.query-0.9.1-py2.4.egg
Searching for zc.catalog>=0.1
Best match: zc.catalog 1.2dev-r74943
Downloading http://download.zope.org/distribution/ zc.catalog-1.2dev_r74943-py2.4.egg

It seems like it is installing zc.catalog-1.2dev_r74943-py2.4.egg
before processing all the dependencies.

I'm running Feisty + python2.4.

Any suggestions would be very helpful.

FWIW, I know zc.catalog but I'm certainly not an egg expert. But this message looks like you are maybe sharing a Python for various installations. Are you maybe using your system Python? Generally not advised for development work...try a standalone one?

To be clear, no release of standalone Zope 3 relies on zc.catalog; it is very, very unlikely to be breaking the Zope 3.3 release or any other. Also, the zc.i18n is a red herring; that doesn't have any dependencies on zc.catalog.

In sum, yes, you have a problem, but I don't think it is inherently with zc.catalog. The standalone Python is the only idea I have off the top of my head.


Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to