Upon a fresh checkout and make of the 3.3.0 tag of Zope3, I get the
following error:

error: Installed distribution zc.catalog 1.2dev-r74943 conflicts with
requirement zc.catalog==0.1.1

I noticed that it installed the later zc.catalog version with hurry.query

Searching for zc.catalog>=0.1
Best match: zc.catalog 1.2dev-r74943

It seems like it is installing zc.catalog-1.2dev_r74943-py2.4.egg
before processing all the dependencies.

I'm running Feisty + python2.4.

Any suggestions would be very helpful.

It's either stale eggs (removing all the eggs and installing again
should work), or the old bug in distutils (can't handle complex
dependencies of eggs). Like if your egg depends on 2 other eggs one
that depends on zc.catalog == 0.1.1, and another egg that depends just
on zc.catalog, the success depends on the order of installation. In
one case -

zc.catalog 1.2 will get installed because it is the newest version,
the egg that depends on old zc.catalog will fail then.

in the other case zc.catalog 0.1.1 will be instaled, and the other egg
will get installed successfully as it can work with an old egg too.
The solution that worked for me was to depend on older version of
zc.catalog directly, so that distutils would see the dependency

Might be something different though.

Zope3-dev mailing list
Unsub: http://mail.zope.org/mailman/options/zope3-dev/archive%40mail-archive.com

Reply via email to