Gaël Pasgrimaud a écrit :
T'as bien gcc ?

C'est pas super parlant comme message d'erreur.

ah oui, faut peut-être faire un apt-get install build-essential(s) pour avoir les trucs de dev.


essais ./bin/buildout -vvvv

2008/5/14 Albert DURANTON <[EMAIL PROTECTED]>:
Merci de ta réponse. J'ai fait ce que tu as dit et j'obtiens maintenant :
"couldn't install: zope.security 3.4.0". Comment installer ce zope security 
3.4.0 ?
Encore merci.


Message du 13/05/08 22:09
De : "Christophe Combelles" <[EMAIL PROTECTED]>
A : "Liste de diffusion des membres de l'association" <[EMAIL PROTECTED]>, "Liste 
générique sur Zope3" <zope3-french-user@lists.afpy.org>
Copie à :
Objet : Re: [Zope3-french-user] [Afpy-membres] z3c

Je cross-poste sur zope3-french-user pour ramener ça dans la bonne liste.


Le plus facile est d'utiliser zopeproject en forçant zope 3.4 :

- tu vires TOUS les paquets zope de ton système (ceux installés avec
apt-get/synatic)
Ensuite :
sudo apt-get install python-setuptools python2.4
sudo python2.4 /usr/bin/easy_install zopeproject
sudo python2.4 /usr/bin/easy_install zc.buildout

par défaut zopeproject utilise des paquets trop récents,
donc il faut le lancer avec:

python2.4 /usr/bin/zopeproject --no-buildout ton_projet

Ensuite tu modifies le fichier buildout.cfg
et tu remplaces la ligne "find-links = ..."  par :

extends = http://download.zope.org/zope3.4/versions.cfg
versions = versions

Ca permet de se fixer de force sur les paquets de zope 3.4

Ensuite tu fais : python2.4 /usr/bin/buildout

A partir de là ton instance doit démarrer :
./bin/ton_projet-ctl fg
ou
./bin/paster serve deploy.ini
ou
./bin/paster serve debug.ini
ou
./bin/ton_projet-ctl debug (pour avoir un shell python avec toutes les
inscriptions du registre, et la zodb accessible directement dans l'objet 'root')

Ensuite tu peux ajouter des paquets z3c dans le setup.py, et relancer ton
buildout pour les récupérer/installer.

Pour les utiliser, il suffit ensuite de les ajouter dans
src/ton_projet/configure.zcml

Christophe

Albert DURANTON a écrit :
Avec le tutoriel "zope3 et les paquets communautaires" traduit par Thierry Floirac je tente une bouvelle fois de suivre 
ses instructions avec ma distribution UBUNTU et j'obtiens la même erreur qu'avec ma DEBIAN lenny. "Couldn't install 
zope.security 3.5.0". J'installe avec la même procédure le paquet "zope.security 3.5.0". Je relance la procédure 
et j'obtiens "Couldn't install zope.interface 3.4.1". J'installe de la même façon zope.interface 3.4.1 et de nouveau 
j'obtiens "couldn't install zope.security 3.5.0".
Je tourne en rond et il me semble que je suis encore loin de pouvoir utiliser la 
procédure des "eggs".
Je remercie d'avance celui qui pourrait me mettre dans le bon chemin qui me 
permettra enfin d'essayer z3c.
Merci d'avance.
Albert

_______________________________________________
AFPy-membres mailing list
[EMAIL PROTECTED]
http://lists.afpy.org/mailman/listinfo/afpy-membres


_______________________________________________
zope3-french-user mailing list
zope3-french-user@lists.afpy.org
http://lists.afpy.org/mailman/listinfo/zope3-french-user



_______________________________________________
zope3-french-user mailing list
zope3-french-user@lists.afpy.org
http://lists.afpy.org/mailman/listinfo/zope3-french-user

_______________________________________________
zope3-french-user mailing list
zope3-french-user@lists.afpy.org
http://lists.afpy.org/mailman/listinfo/zope3-french-user



_______________________________________________
zope3-french-user mailing list
zope3-french-user@lists.afpy.org
http://lists.afpy.org/mailman/listinfo/zope3-french-user

Répondre à