Salut,
essaie de rester dans la liste zope3, elle sert à ça

Albert DURANTON a écrit :
 j'obtiens ce message alors que je ne l'obtenais pas avant.
   " ZopeXMLConfigurationError: File 
"/home/albert2/sandbox/zcontact/src/zcontact/configure.zcml", line 4.2
    ConfigurationError: ('Unknown directive', None, u'interface')"
il vient de :<configure
    xmlns:zope="http://namespaces.zope.org/zope"; >
<interface
        interface=".layer.IZContactBrowserLayer"
        type="zope.publisher.interfaces.browser.IBrowserSkinType"
        name="ZContact"
        />

Soit tu mets :
xmlns="http://namespaces.zope.org/zope";
puis:
<interface ...


Ou sinon :
xmlns:zope="http://namespaces.zope.org/zope";
puis:
<zope:interface ...

Il est copié dans le z3cTutorial.fr.
J'ai vérifié les eggs, j'ai lancé le buildout. Il y a bien package 
include="zope.interface'

include="zope.interface' ne sert à rien, car il n'y a pas de ZCML dans zope.interface. Il n'a pas non plus de meta.zcml.
La directive <interface> provient de zope.component
(tu peux retrouver ca en allant dans l'apidoc → réf ZCML → zope → interface)

j'y ai ajoute un file="meta.zcml"
ça ne marche plus. Pourquoi ?
quelqu'un peut-il m'expliquer le genre de problème rencontré.
j'ai essayé toutes les solutions avec xmlns. "..zope.org/zope", "<zope.interface 
.."
Albert

_______________________________________________
AFPy-membres mailing list
[EMAIL PROTECTED]
http://lists.afpy.org/mailman/listinfo/afpy-membres



_______________________________________________
zope3-french-user mailing list
zope3-french-user@lists.afpy.org
http://lists.afpy.org/mailman/listinfo/zope3-french-user

Répondre à