[Alen Stanisic]
> I managed to download Zope 3.1b (thanks Tim and Stephan),

Thank Stephan and Jim -- I just built the Windows installers, and I
can guarantee testUmask doesn't fail on Windows <wink -- it's not even
tried on Windows>.

> when running 'make check' I get the following error:
> Failure in test testUmask (zdaemon.tests.testzdrun.ZDaemonTests)
> Traceback (most recent call last):
>  File
> "/usr/local/zope3/install/Zope-3.1.0b1/build/lib.linux-i686-2.3/zdaemon/
> tests/testzdrun.py", line 260, in testUmask
>    self.assert_(not os.access(path, os.W_OK))
>  File "/usr/lib/python2.3/unittest.py", line 278, in failUnless
>    if not expr: raise self.failureException, msg
> AssertionError
> It seems to be a problem with permissions on a temp file created during
> the test.
> I then tried installing ZopeX3-3.0.0 and got exactly the same error.
> This is the only error I get when running 'make check' should this be of
> major concern?
> (Running: Python 2.3.5, GCC 3.3.5, Debian, Intel Pentium III)

The only other report of this I recall is here:


The cause was that the poster ran the tests as root.  If that's what
you did, don't run the tests (or Zope!) as root.  If that's not what
you did, it will take some digging on your end.
Zope3-users mailing list

Reply via email to