Hi,
I just downloaded zope3 ( ZopeX3-3.0.0.tar.gz) and issued the
'configure', and 'make' commands. When I try a 'make check', I get
multiple errors (see bottom of message).
I am including below the output from what I think are relevant commands.

I'd appreciate any help you can provide in diagnosing these errors.

-g

---

$: uname -a
Linux xxx 2.6.9-11-rfs #1 Tue Jun 14 08:27:18 MDT 2005 i686 i686 i386 GNU/Linux

---

$: ./configure 

Configuring Zope X3 installation

Testing for an acceptable Python interpreter...

Python version 2.3.3 found at /usr/local/bin/python
Python version 2.3.3 found at /usr/local/bin/python2.3
Python version 2.3.4 found at /usr/bin/python

The optimum Python version (2.3.4) was found at /usr/bin/python.

---

$: make check
/usr/bin/python install.py -q build
/usr/bin/python test.py -v
Running UNIT tests at level 1
Running UNIT tests from
/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3
..............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

Error in test checkReconnectSwitch
(ZEO.tests.testConnection.FileStorageReconnectionTests)
Traceback (most recent call last):
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZEO/tests/ConnectionTests.py",
line 122, in tearDown
    os.waitpid(pid, 0)
OSError: [Errno 10] No child processes

...............


[snip: many error messages]

======================================================================
ERROR: checkReadMethods (ZEO.tests.testZEO.MappingStorageTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZEO/tests/testZEO.py",
line 136, in tearDown
    os.waitpid(pid, 0)
OSError: [Errno 10] No child processes

[snip: error messages]

======================================================================
FAIL: testUmask (zdaemon.tests.testzdrun.ZDaemonTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/zdaemon/tests/testzdrun.py",
line 244, in testUmask
    self.assert_(not os.access(path, os.W_OK))
  File "/usr/lib/python2.3/unittest.py", line 278, in failUnless
    if not expr: raise self.failureException, msg
AssertionError

======================================================================
ERROR: check7ZODBThreads (ZODB.tests.testMappingStorage.MappingStorageTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZODB/tests/MTStorage.py",
line 216, in check7ZODBThreads
    self._checkNThreads(7, ZODBClientThread, db, self)
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZODB/tests/MTStorage.py",
line 205, in _checkNThreads
    t.join(60)
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZODB/tests/MTStorage.py",
line 39, in run
    self.runtest()
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZODB/tests/MTStorage.py",
line 69, in runtest
    self.commit(d, i)
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZODB/tests/MTStorage.py",
line 75, in commit
    transaction.commit()
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/transaction/__init__.py",
line 31, in commit
    manager.get().commit(sub)
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/transaction/_transaction.py",
line 314, in commit
    s.afterCompletion(self)
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZODB/Connection.py",
line 747, in afterCompletion
    self._flush_invalidations()
  File 
"/usr2/local/buildirs/zope_plone/ZopeX3-3.0.0/build/lib.linux-i686-2.3/ZODB/Connection.py",
line 750, in _flush_invalidations
    self._inv_lock.acquire()
AttributeError: 'Connection' object has no attribute '_inv_lock'

----------------------------------------------------------------------
Ran 3970 tests in 383.228s

FAILED (failures=1, errors=18)
make: *** [check] Error 1
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to