Am Montag, 25. Juli 2005 15:47 schrieb Fred Drake:
> You need to make the title attribute of the new adapter writable.  Use
> something like:
>   <class class=".contentitem.factory">
>     <require
>         permission="zope.View"
>         interface=""
>         />
>     <require
>         permission="zope.ManageContent"
>         set_attributes="created modified title"
>         />
>   </class>

Mmmhh, I'm wondering why it used to work about 2 weeks ago... Why are these 
class declarations necessary? Everything is file-based code, so AFAIK there 
should not be a problem with permissions.

Anyways, I am not able to make it work with that. It's still the same 

  File "/home/florian/Zope3/src/zope/app/container/browser/", line 
169, in _extractContentInfo
    info['retitleable'] = canWrite(dc, 'title')
  File "/home/florian/Zope3/src/zope/security/", line 96, in 
    checker.check_setattr(obj, name)

I've also tried to change the zope.ManageContent to zope.Public, but does 
change nothing.


Zope3-users mailing list

Reply via email to