On Oct 18, 2005, at 3:47 PM, Tim Penhey wrote:

Hi All,

I am using Kubuntu 5.10 (Breezy Badger) and after failing to use the
pre-packaged zope3, I tried to download and install the one from zope.org.

Using Python 2.4.2 and gcc 4.0.2.

Since I don't have python2.3 installed (and env 'aint in /bin), I had to
change the first line of the test.py from
    #!/bin/env python2.3
    #!/usr/bin/env python

./install.py build worked fine, however ./test.py -v fails on one test:

Failure in test testRunIgnoresParentSignals
Traceback (most recent call last):
  File "/usr/lib/python2.4/unittest.py", line 260, in run
"/home/tim/Zope-3.1.0/build/lib.linux-i686-2.4/zdaemon/tests/ testzdrun.py",
line 237, in testRunIgnoresParentSignals
self.assert_(is_started, "spawned process failed to start in a minute")
  File "/usr/lib/python2.4/unittest.py", line 309, in failUnless
    if not expr: raise self.failureException, msg
AssertionError: spawned process failed to start in a minute

test was run as normal user.

What next?  Given that I am trying to go through the text of "Zope 3
Developer's Handbook" and "Web Component Development with Zope 3" is it
something that is going to matter to me?


Is it a known problem, bug, or
problem with my install?

Known problem AFAIK. I believe this is the same one as Jim addressed here: http://mail.zope.org/pipermail/zope3-dev/2005-September/ 015851.html


Zope3-users mailing list

Reply via email to