Sorry, where are you looking at this.

In the release, the permissions are correct.

In an installation created with Python 2.4, the bits are not.

What version of Python are you using?


Paul Dumais wrote:
Sent this using the wrong  account:

On 10/26/05, Paul Dumais <[EMAIL PROTECTED]> wrote:

Hi Jim,

The execute bit seems OK:

-rwxr-xr-x  1 root root    59 2005-10-02 12:48

I get more errors if I run as root (the above one included). Ubuntu
does something tricky to the root account so that you cannot su root.
You have to sudo 'command' to do root tasks. I suspect this difference
is why I get more errors when I do sudo make check.

Since I am running make check as a user on the system, I though I
would try chown 'user' Doing this gives the same error
when I run 'make check'.

I guess this begs the question: should I be looking to chown 'user' a
bunch of files and directories (since I plan to run everything as a
user)? Should I be looking to get rid of the su  root lockout feature
of Ubuntu? Hopefully none of this should be necessary since my 'user'
is a superuser.

I guess this is not a major problem, since Steve is safely ignoring
the error. Thanks for the quick replies! I read some posts from August
that mentioned that it may just be an issue of a slower machine (my
machine has a few other processes running on it). Increasing the error
threshold to something higher may be what's needed?


On 10/26/05, Jim Fulton <[EMAIL PROTECTED]> wrote:

Jim Fulton wrote:

Stephan Richter wrote:

On Wednesday 26 October 2005 16:26, Jim Fulton wrote:

AssertionError: spawned process failed to start in a minute

Is this serious? How could I get this test to pass?

Don't run the tests as root.

I see this error sporatically using a non-root user as well. I just
never worry about it. :-)

Right.  This is not what I thought it was.

This is something that I diagnosed and thought I fixed
a few weeks ago.

I'll look at it.

OK, Tim helped me remember what was going on with this.

I predict you can make this test pass by setting the execute bit on
the script in zdaemon/tests in the installation.
This test is trying to execute this script and can't because the
execute bits got cleared in the release process.

The test really should be rewritten to write the shell script itself
and set the permissions to whatever it wants.


Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714  
Zope Corporation

Zope3-users mailing list

Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714  
Zope Corporation
Zope3-users mailing list

Reply via email to