On Wed, Oct 26, 2005 at 08:39:41PM -0600, Paul Dumais wrote:
| Sent this using the wrong  account:
| On 10/26/05, Paul Dumais <[EMAIL PROTECTED]> wrote:

| > I get more errors if I run as root (the above one included).

One of the additional errors you will get is the test that verifies
that file access works correctly.  The test fails as root because root
is granted access when the test expects to be denied access.

| > Ubuntu
| > does something tricky to the root account so that you cannot su root.
| > You have to sudo 'command' to do root tasks. I suspect this difference
| > is why I get more errors when I do sudo make check.

Have you ever tried 'sudo su'?  Also try 'sudo passwd', if you want.
Ubuntu doesn't have you set a root password during installation.  I
think there is no valid password for root.  That certainly avoids any
potential for someone to brute-force attack it.  Instead, they set up
the first user to be able to run any command, as root, via 'sudo'.
This includes, of course, su and bash.  Thus you can get a root shell
quite easily (once you're logged in).  I suspect, though haven't
actually verified, that if you set a password for root you will then
be able to 'su' without sudo.


Whoever gives heed to instruction prospers,
and blessed is he who trusts in the Lord.
        Proverbs 16:20
www: http://dman13.dyndns.org/~dman/            jabber: [EMAIL PROTECTED]

Attachment: signature.asc
Description: Digital signature

Zope3-users mailing list

Reply via email to