Hi Tahara,

On 10/22/05, TAHARA Yusei <[EMAIL PROTECTED]> wrote:
> Hi.
> At Thu, 20 Oct 2005 11:48:41 +1000,
> Alen Stanisic wrote:
> > I noticed that if I adapted a persistent content type and created a
> > catalog with index on one of the fields provided by the adapter
> > interface, the indexing worked for all of my content that was there at
> > time of catalog creation.  But any new content objects created after
> > catalog creation would not get indexed though.
> It doesn't make sense to me.
> I use catalog for my application and indexing worked after added
> new content. I think catalog does not index object that was added before
> catalog creation.

I think indexing will work for objects added after IntId Utility is
added even if catalog is not there at the time.

> catalog has event subscribers in zope/app/catalog/configure.zcml
> and does automatic indexing for adaptable objects.

My adapter provides just a Bool type field and I created my fieldindex
for that field.  I will have to investigate my problem further now
that I know that indexing on adapter interfaces should work.

Zope3-users mailing list

Reply via email to