Hi Sven
  

> -----Original Message-----
> From: [EMAIL PROTECTED] 
> [mailto:[EMAIL PROTECTED] On Behalf Of Sven Schomaker
> Sent: Monday, November 14, 2005 8:55 AM
> To: zope3-dev; Zope3 users list
> Subject: [Zope3-Users] Maybe bug in pagetemplate parser?
> 
> Hi all, 
> 
> currently I'm trying to output a pretty tiny code
> snippet in a page template, but the compilation 
> fails due to a nesting error. It seems as if the 
> pt engine erroneously parses the following snippet,
> complaining about a nesting error on the closing
> div:
> 
> 
> <script type="text/javascript">
>    <!--
>    document.write('<div id="LOADING_DOCUMENT_HINT">Loading document.
> Please be patient...</div>');
>    //-->
> </script>
> 
> It also fails if I declare the whole script 
> content as XML CDATA section using <![CDATA[ ...
> 
> Is this is user error or a parser bug? Some
> help is very appreciated:-)

This is a bug, please add a issue to the bugtracker!
The parser engine tries to interprete the <div> tag.

I guess the normal hacks used in onther script languages will
work. Try this:

<script type="text/javascript">
   <!--
   document.write('<d'+'iv id="LOADING_DOCUMENT_HINT">Loading document.
Please be patient...</d'+'iv>');
   //-->
</script> 

> Greetings Sven
> 
> _______________________________________________
> Zope3-users mailing list
> Zope3-users@zope.org
> http://mail.zope.org/mailman/listinfo/zope3-users
> 

_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to