John Smith wrote:
Dear Jim,

I was unable to import IDatabase from ZODB.interfaces,
although I could import IDataManager and IConnection.

However, when I tried:

root = zapi.getUtility(IDataManager)

I got a componentlookuperror. (The same error happens
with IConnection).

Did you try IBuddy? ;)

Any thoughts?

I'm guessing that you are using Zope 3.0.
The registration of databases as utilities wasn't added
until 3.1.

Jim

--
Jim Fulton           mailto:[EMAIL PROTECTED]       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to