Hi everybody.

I know a similar question was already post here:
http://mail.zope.org/pipermail/zope3-users/2005-October/001142.html

But I didn't understood well Stephan's answer (sorry!). I think I'm looking for
a solution like Garrett's (though it wasn't specific).

I'm just wondering which *-configure.zcml or *-meta.zcml files can be removed
from the etc/package-includes dir of an instance in order to get running the
"minimum" Zope3 but in a stable way.

For example, I know my application won't be using any sql related stuff, so I
think is possible to remove the sqlscript-configure.zcml file. I believe the
less *-configure.zcml and *-meta.zcml files are in this directory the faster
Zope3 loads, right?

But if I remove every file except the apidoc related, then Zope3 won't even
start because it complains about preference-*.zcml files. I got Zope3 running
again testing and reading error messages (just like Garrett suggests), but I
think this way could be dangerous in case I miss something important.

Is this issue important or there's no real difference in how many packages get
included on start?

Thanks.


        
                
__________________________________ 
Yahoo! for Good - Make a difference this year. 
http://brand.yahoo.com/cybergivingweek2005/
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to