hi!

An error occured within my own module, and I tried to look at
ErrorReportingUtility to find out what happened. However, instead of
comprehensible report I got another "System error occured" acreen...
Looking at the stout of Zope, I found this:


I got this:

2006-02-13T10:51:16 ERROR SiteError
http://localhost:9080/++etc++site/default/RootErrorReportingUtility/@@index.html
Traceback (most recent call last):
  File "/opt/Zope3.2//lib/python/zope/publisher/publish.py", line 138,
in publish
    result = publication.callObject(request, object)
  File
"/opt/Zope3.2//lib/python/zope/app/publication/zopepublication.py", line
161, in callObject
    return mapply(ob, request.getPositionalArguments(), request)
  File "/opt/Zope3.2//lib/python/zope/publisher/publish.py", line 113,
in mapply    return debug_call(object, args)
  File "/opt/Zope3.2//lib/python/zope/publisher/publish.py", line 119,
in debug_call
    return object(*args)
  File
"/opt/Zope3.2//lib/python/zope/app/pagetemplate/simpleviewclass.py",
line 44, in __call__
    return self.index(*args, **kw)
  File
"/opt/Zope3.2//lib/python/zope/app/pagetemplate/viewpagetemplatefile.py",
line 83, in __call__
    return self.im_func(im_self, *args, **kw)
  File
"/opt/Zope3.2//lib/python/zope/app/pagetemplate/viewpagetemplatefile.py",
line 51, in __call__
    sourceAnnotations=getattr(debug_flags, 'sourceAnnotations', 0),
  File "/opt/Zope3.2//lib/python/zope/pagetemplate/pagetemplate.py",
line 118, in pt_render
    return output.getvalue()
  File "/opt/lib/python2.4/StringIO.py", line 271, in getvalue
    self.buf += ''.join(self.buflist)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 0:
ordinal not in range(128)

I think, this is an error in Zope3 as I belive NOTHING should EVER
prevent looking at error log!


Regards,
Roman
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to