Joshua Zeidner wrote:



Hello,

I am using the latest Kubuntu 5.10 Breezy Badger and I am trying to install Zope3. Its a fresh Kubuntu install. I downloaded the Zope-3.2.0.tgz file and unpacked it. I then ran the configure script. Then I ran make and get the following problem. The same thing happens when I use the SVN repos. It appears to have something to do with glibs, I checked for the existence of these files and they are there. Here is some of the shell output:

---------------------------------------------------------------------------------------

[EMAIL PROTECTED]:~/zope/Zope-3.2.0$ make
/usr/bin/python install.py -q build
In file included from /usr/lib/gcc/i486-linux-gnu/4.0.2/include/syslimits.h:7,
                 from /usr/lib/gcc/i486-linux-gnu/4.0.2/include/limits.h:11,
                 from /usr/include/python2.4/Python.h:18,
from Dependencies/zope.interface-Zope-3.2.0/zope.interface/_zope_interface_coptimizations.c:15: /usr/lib/gcc/i486-linux-gnu/4.0.2/include/limits.h:122:61: error: limits.h: No such file or directory In file included from Dependencies/zope.interface-Zope-3.2.0/zope.interface/_zope_interface_coptimizations.c:15: /usr/include/python2.4/Python.h:32:19: error: stdio.h: No such file or directory

You are missing the Python/C development development libraries.

You will need to get apt-get python-devel among other things.

Suresh

_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to