Eric,

If you're on Mac OS X Tiger (10.4), you could try the Zope 3.2.1 OS X installer I recently built. It's a native PowerPC build, and I plan to release an Intel build soon.


http://www.zope.org/Members/kamalgill/Zope-3.2.1-Installer-OSX- PPC_build2006041702.zip/file_view

 - Kamal


--
Kamal Gill - [EMAIL PROTECTED]
http://www.adaptivewave.com
Content Management Made Simple



On Apr 17, 2006, at 1:45 PM, Eric Williams wrote:

Hi all. I’m having trouble building Zope on OS X. I’ve searched all over for a solution but could not find anything. Any help is much appreciated!



I start with ./configure, as per the readme:



   $ ./configure



   Configuring Zope installation



   Testing for an acceptable Python interpreter...



Python version 2.4.3 found at /Library/Frameworks/ Python.framework/Versions/Current/bin/python

Python version 2.4.3 found at /Library/Frameworks/ Python.framework/Versions/Current/bin/python2.4

   Python version 2.3.5 found at /usr/bin/python



   No suitable Python version found. You should install

   Python version 2.4.2 before continuing. Versions

   2.4.1 also work, but not as optimally.



This output seems somewhat odd, since it found version 2.4.3. So I run ./configure with the –with-python option:



$ ./configure --with-python /Library/Frameworks/Python.framework/ Versions/Current/bin/python



   Configuring Zope installation



Using Python interpreter at /Library/Frameworks/Python.framework/ Versions/Current/bin/python



Then I run make:



   $ make

/Library/Frameworks/Python.framework/Versions/Current/bin/python install.py -q build

gcc: installation problem, cannot exec 'i686-apple-darwin8- gcc-4.0.0': No such file or directory

In file included from Dependencies/BTrees-Zope-3.2.1/BTrees/ BTreeModuleTemplate.c:15,

from Dependencies/BTrees-Zope-3.2.1/BTrees/ _fsBTree.c:70:



This is followed by nearly 300 lines of error output, which I can provide if necessary. The thing that concerns me is “i686-apple- darwin8-gcc-4.0.0” … I’m running on PowerPC architecture.



gcc –v returns the following:



   Reading specs from /usr/lib/gcc/powerpc-apple-darwin8/4.0.0/specs

Configured with: /private/var/tmp/gcc/gcc-4061.obj~8/src/ configure --disable-checking

--prefix=/usr --mandir=/share/man --enable-languages=c,objc,c+ +,obj-c++

--program-transform-name=/^[cg][^+.-]*$/s/$/-4.0/ --with-gxx- include-dir=/include/gcc/darwin/4.0/c++

--build=powerpc-apple-darwin8 --host=powerpc-apple-darwin8 -- target=powerpc-apple-darwin8

   Thread model: posix

   gcc version 4.0.0 20041026 (Apple Computer, Inc. build 4061)



Any ideas?



Thanks,

Eric

_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users


_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to