Hello,
I've this piece of working code which generates deprecation warnings with the 
new API:

registration = UtilityRegistration("cs users", 
zope.app.authentication.interfaces.IAuthenticatorPlugin, principal_folder)

registration_manager = pau.registrationManager
registration_manager.addRegistration(registration)
registration.status = u'Active'

My problem is: where do I get a class instance that implements 
zope.component.interfaces.IComponentRegistry? (which is AFAIK needed for the 
new registration)

Thanks,

Florian
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to