Kamal Gill wrote:
I'm not sure if this will help, but here's my build notes from the Zope 3.2.1 OS X Installer (with OSX-specific details removed)...
I gave it a shot

  ./configure --prefix=/opt/Zope-3.2.1/Python-2.4.3 --with-readline
I did that, substituting the directory I am using

This is where I still have trouble.  I get the same error I wrote in my
first post on this subject.  I tried putting a few debugging print
statements in


and the result was interesting but I still don't understand what is
the problem.  It seems to be going through a list of dependencies.
The directory where I get the error is

I see in that directory is a SETUP.cfg so I looked at it.  I also see
that there is a configure.zcml which seems like it would not match
the *-configure.zcml from the error message.  Just for fun I tried
editing SETUP.cfg and saw it has the string *-configure.zcml so I
changed it to *configure.zcml.  Now the make goes farther than before
but bombs later with the same kind of problem.  I repeated this
process a few times and kept getting farther but I suspect that
I am not really solving the problem.

Even though this is Solaris, I am wondering if my problem is more
generic and I hope that there is someone out there who understands
this and can make sense out of these errors

Damon Register
Zope3-users mailing list

Reply via email to