there are problems running functional test on my computer and I need some advice.

If I start the unittest  with:

cd /Users/peter/z3/j2/lib
../bin/test -vpu --dir boom

All tests from the tutorial "Zope3 In 30 Minutes" are executed.

with  ../bin/test -vpf --dir boom

an Error occurs:

Running tests at level 1
Running zope.app.testing.functional.Functional tests:
  Set up zope.app.testing.functional.Functional
Traceback (most recent call last):
  File "../bin/test", line 47, in ?
File "/Users/peter/z3/Zope3/src/zope/testing/testrunner.py", line 245, in run
    failed = run_with_options(options)
File "/Users/peter/z3/Zope3/src/zope/testing/testrunner.py", line 395, in run_with_options
    setup_layers, failures, errors)
File "/Users/peter/z3/Zope3/src/zope/testing/testrunner.py", line 566, in run_layer
    setup_layer(layer, setup_layers)
File "/Users/peter/z3/Zope3/src/zope/testing/testrunner.py", line 650, in setup_layer
File "/Users/peter/z3/Zope3/src/zope/app/testing/functional.py", line 198, in setUp
File "/Users/peter/z3/Zope3/src/zope/app/testing/functional.py", line 139, in __init__
    self.app = Debugger(self.db, config_file)
File "/Users/peter/z3/Zope3/src/zope/app/debug/debug.py", line 35, in __init__
File "/Users/peter/z3/Zope3/src/zope/app/appsetup/appsetup.py", line 110, in config
    context = xmlconfig.file(file, context=context, execute=execute)
File "/Users/peter/z3/Zope3/src/zope/configuration/xmlconfig.py", line 554, in file
    include(context, name, package)
File "/Users/peter/z3/Zope3/src/zope/configuration/xmlconfig.py", line 483, in include
    f = openInOrPlain(path)
File "/Users/peter/z3/Zope3/src/zope/configuration/xmlconfig.py", line 394, in openInOrPlain
    fp = open(filename)
IOError: [Errno 2] No such file or directory: '/Users/peter/z3/j2/lib/ ftesting.zcml'
[EMAIL PROTECTED]:~/z3/j2/lib

Are there some special configuration steps necessary for a zope- instance and/or the boom-package?

2. Test:

moved "boom"-Folder to Zope3/src
cd Zope3

and run:

python test -vpf --dir boom

all tests failed.

after inserting the following lines:

from boom.bookmarker import BookMarker
from boom.bookmarker import Mark

all tests pass but I can't run the tests from  instance (j2).


Zope3-users mailing list

Reply via email to