I've tried to get WingIDE to work for debugging Zope3 but have only had
limited success.  I've followed the instructions at wingware.com where it
tells you to add the wingdbstub.  I added 'import wingdbstub' in
$ZOPEINSTANCE/bin/runzope and it will break on errors but will not break on

Other instructions tells you to make sure there is only _one_ thread, and I
finally found a setting in zope.app.twisted.schema.xml where I changed it to

  <key name="threads" datatype="integer" default="1"> <== Changed to 1
      The number of threads which should be used to serve requests.

      The threads are placed in a pool and are used to serve requests
      received from the servers configured using &lt;server&gt;
      sections.  This does not constrain the total number of threads
      used by the application server; additional threads may be used
      for internal purposes.

Still no success.

Has anyone had any success with debugging with WingIDE?



Zope3-users mailing list

Reply via email to