Hi Mike. Can you confirm you have pyopenssl-0.6 installed and proper paths in your config. It should look like this in your config if you are using the default files supplied.

   type HTTPS
   address 8443
   privatekeypath $CONFDIR/server.pem
   certificatepath $CONFDIR/server.pem

Just to let you know I am running on mac and everything is fine for me. I am on OSX 10.3.


Mike Emerick wrote:

I have been trying to get the SSL server and the SSH server running with Zope 3. When I uncomment ssh server in the zope.conf file I get the following.

 Traceback (most recent call last):
  File "./runzope", line 48, in ?
  File "./runzope", line 44, in run
    main(["-C", CONFIG_FILE] + sys.argv[1:])
File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/main.py", line 74, in main
    service = setup(load_options(args))
File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/main.py", line 151, in setup
    service = server.create(db)
File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/server.py", line 204, in create
    servertype = zapi.getUtility(IServerType, self.type)
File "/usr/local/Zope-3.2.1/lib/python/zope/component/__init__.py", line 257, in getUtility
    raise ComponentLookupError(interface, name)
zope.component.interfaces.ComponentLookupError: (<InterfaceClass zope.app.twisted.interfaces.IServerType>, 'SFTP')

I have looked every all over for a solution. I can confirm this on Suse Linux 10 and Mac OS 10.4 and 10.3. Has anyone seen this. SSL gives a similar error just replace the SFTP with SSL.

Zope3-users mailing list

Zope3-users mailing list

Reply via email to