SSL (and therefore HTTPS, SFTP) is supporterd but not yet enabled,
from the 3.2.0 release notes 
(http://www.zope.org/Wikis/DevSite/Projects/ComponentArchitecture/Zope320):

  Most Important Changes Since 3.1

  * The ZServer? has been replaced with the Twisted server. The
    Twisted server supports all that the ZServer? supporting has well
    has HTTP over SSL natively and SFTP ***(disabled for now because
    of error handling problems)***....

So you will have to wait - other people are interested in SSL, too (I
remember to have seen a discussion on on one of the lists zope3-users
or -dev, I just don't remember where at the moment), but it seems the
problem was not considered of a high priority for most of the
developers - you can of course use SSL by running Zope behind Apache.

I never heard that Zope itself was offering SSH but I might
be wrong.

-Andreas




On Fri, Jun 16, 2006 at 03:30:11PM -0500, Mike Emerick wrote:
> 
> 
>   I have been trying to get the SSL server and the SSH server  
> running with Zope 3. When I uncomment ssh server in the zope.conf  
> file I get the following.
> 
>  Traceback (most recent call last):
>   File "./runzope", line 48, in ?
>     run()
>   File "./runzope", line 44, in run
>     main(["-C", CONFIG_FILE] + sys.argv[1:])
>   File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/main.py",  
> line 74, in main
>     service = setup(load_options(args))
>   File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/main.py",  
> line 151, in setup
>     service = server.create(db)
>   File "/usr/local/Zope-3.2.1/lib/python/zope/app/twisted/ 
> server.py", line 204, in create
>     servertype = zapi.getUtility(IServerType, self.type)
>   File "/usr/local/Zope-3.2.1/lib/python/zope/component/ 
> __init__.py", line 257, in getUtility
>     raise ComponentLookupError(interface, name)
> zope.component.interfaces.ComponentLookupError: (<InterfaceClass  
> zope.app.twisted.interfaces.IServerType>, 'SFTP')
> 
> 
> I have looked every all over for a solution.  I can confirm this on  
> Suse Linux  10 and Mac OS 10.4 and 10.3. Has anyone seen this.   SSL  
> gives a similar error just replace the SFTP with SSL.
> 
>                                                               Thanks,
>                                                                               
> Mike _______________________________________________
> Zope3-users mailing list
> Zope3-users@zope.org
> http://mail.zope.org/mailman/listinfo/zope3-users
> 
> 
> !DSPAM:4493219a117902252880176!
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to