Hi,

I'm new to Zope and I'm having trouble getting the instance I have created to run. I'm using Zope 3.2.0 on Windows 2000.


When I call 'runzope' I get the following python traceback:

Traceback (most recent call last):
 File "bin/runzope", line 48, in ?
   run()
 File "bin/runzope", line 44, in run
   main(["-C", CONFIG_FILE] + sys.argv[1:])
File "C:\Python24\Lib\site-packages\zope\app\twisted\main.py", line 74, in main
   service = setup(load_options(args))
File "C:\Python24\Lib\site-packages\zope\app\twisted\main.py", line 139, in setup
   zope.app.appsetup.config(options.site_definition, features=features)
File "C:\Python24\Lib\site-packages\zope\app\appsetup\appsetup.py", line 110, in config
   context = xmlconfig.file(file, context=context, execute=execute)
File "C:\Python24\Lib\site-packages\zope\configuration\xmlconfig.py", line 554, in file
   include(context, name, package)
File "C:\Python24\Lib\site-packages\zope\configuration\xmlconfig.py", line 490, in include
   processxmlfile(f, context)
File "C:\Python24\Lib\site-packages\zope\configuration\xmlconfig.py", line 345, in processxmlfile
   parser.parse(src)
 File "C:\Python24\Lib\xml\sax\expatreader.py", line 107, in parse
   xmlreader.IncrementalParser.parse(self, source)
 File "C:\Python24\Lib\xml\sax\xmlreader.py", line 123, in parse
   self.feed(buffer)
 File "C:\Python24\Lib\xml\sax\expatreader.py", line 207, in feed
   self._parser.Parse(data, isFinal)
 File "C:\Python24\Lib\xml\sax\expatreader.py", line 348, in end_element_ns
   self._cont_handler.endElementNS(pair, None)
File "C:\Python24\Lib\site-packages\zope\configuration\xmlconfig.py", line 326, in endElementNS
   self.context.end()
File "C:\Python24\Lib\site-packages\zope\configuration\config.py", line 544, in end
   self.stack.pop().finish()
File "C:\Python24\Lib\site-packages\zope\configuration\config.py", line 690, in finish
   actions = self.handler(context, **args)
File "C:\Python24\Lib\site-packages\zope\configuration\xmlconfig.py", line 490, in include
   processxmlfile(f, context)
File "C:\Python24\Lib\site-packages\zope\configuration\xmlconfig.py", line 345, in processxmlfile
   parser.parse(src)
 File "C:\Python24\Lib\xml\sax\expatreader.py", line 107, in parse
   xmlreader.IncrementalParser.parse(self, source)
 File "C:\Python24\Lib\xml\sax\xmlreader.py", line 123, in parse
   self.feed(buffer)
 File "C:\Python24\Lib\xml\sax\expatreader.py", line 207, in feed
   self._parser.Parse(data, isFinal)
 File "C:\Python24\Lib\xml\sax\expatreader.py", line 348, in end_element_ns
   self._cont_handler.endElementNS(pair, None)
File "C:\Python24\Lib\site-packages\zope\configuration\xmlconfig.py", line 326, in endElementNS
   self.context.end()
File "C:\Python24\Lib\site-packages\zope\configuration\config.py", line 544, in end
   self.stack.pop().finish()
File "C:\Python24\Lib\site-packages\zope\configuration\config.py", line 689, in finish
   args = toargs(context, *self.argdata)
File "C:\Python24\Lib\site-packages\zope\configuration\config.py", line 1381, in toargs
   args[str(name)] = field.fromUnicode(s)
File "C:\Python24\Lib\site-packages\zope\configuration\fields.py", line 141, in fromUnicode
   raise schema.ValidationError(v)
zope.configuration.xmlconfig.ZopeXMLConfigurationError: File "C:\ZopeInstance\etc\site.zcml", line 3.2-3.50 ZopeXMLConfigurationError: File "C:\ZopeInstance\etc\package-includes\sendmail-meta.zcml", line 1.0-1.51 ConfigurationError: ('Invalid value for', 'package', 'ImportError: Module zope has no global sendmail')

Any help in resolving this error would be appreciated,

Thanks

Luke Benstead.
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to