First off, let me say that I'm a total newbie to both Zope3 and Apache.  So
if this is an RTFM situation, please let me know and point me to the docs. 
But after two hours of googling and searching, all I can seem to
find is stuff relevant to Zope2.

I'm trying to do something (I thought was) really simple:  get Apache
(2.0.58) to serve as the front-end to a currently running ZServer process
(with Zope 3.2.1).

Judging from what I've found in my scrounging around the internet, I cooked
up the following chunk of httpd.conf:

NameVirtualHost localhost:8080 # The ZServer process's port
<VirtualHost localhost:8080>
    Servername localhost
    DocumentRoot /absolute/path/to/apache2/htdocs
    ErrorLog var/apache2/log/zope.log
    CustomLog var/apache2/log/zope.log common
    RewriteEngine On
    RewriteLog var/apache2/log/rewrites.log
    RewriteLogLevel 0
    RewriteRule ^/zope(/?.*) http://localhost:8080/$1 [P,L]

So I start up the ZServer with zopectl... no problems.  Then I fire up
apache (listening on port 8000) with apachectl... no problems.

So then I visit localhost:8000 and I get the apache test page.  I visit
localhost:8080 and I get the default Zope3 page.  But when I try to visit
localhost:8000/zope, I get a 404 error.

zope.log is empty, rewrites.log is empty, and the apache error_log only has
the client error requesting the non-existent resource.

So I obviously don't know what I'm doing with this <VirtualHost> block. 
Could somebody please help me out?

Thanks a bunch.

Steve Juranich
Tucson, AZ

Zope3-users mailing list

Reply via email to