Bussiere:

It would help a lot if you would specify exactly which operating system 
you are using, and
if linux, which distribution.

For example, in Debian linux (testing or unstable), you would need to 
install the appropriate
postgresql-server-dev-7.4, postgresql-server-dev-8.0, or 
postgresql-server-dev-8.1 depending
on which postgresql was being used as the back-end.

Note:  at one time Red Hat and its derivatives had another problem, they 
put the inlcude files
in an odd place. 
See http://initd.org/tracker/psycopg/wiki/PsycopgOne
See also http://initd.org/tracker/psycopg/wiki/PsycopgTwoInstall

You may have a similar problem with mxdatetime headers.

jim

[EMAIL PROTECTED] wrote on 
08/22/2006 06:37:46 PM:

> yes but when i try to install psycop 1 it says to me :
> checking PostgreSQL version... configure: error: missing PostgreSQL 
headers
> when i make a ./configure
> 
> it's driving me crazy that's why i'am looking for a good tutorial for
> making it (installing zope3 and psycop)
> 
> regards
> i'am desesperate
> Bussiere
> 
> On 8/22/06, Philipp von Weitershausen <[EMAIL PROTECTED]> wrote:
> > bussiere maillist wrote:
> > > it's been more tnah  two month that i'am trying to install zope3 and
> > > make psycopgda working with it.
> > >
> > > So if someone have a good tutorial explaining how to do that and if 
it
> > > could work i'll be glad.
> > >
> > > And i'am ready to pay about 40$ (by paypal if needed) if it works, i
> > > really need it and i'am desesperate to find a solution.
> > >
> > >
> > > i've already tried this tutorials here
> > > http://dfwpython.org/Zope3Notes/PgConnectorInstall
> > > with the psycopg2 version but it says to  me :
> > >
> > > ZopeXMLConfigurationError: File
> > > "/Zope3/etc/package-includes/psycopgda-configure.zcml", line 
1.0-1.31
> > >    ZopeXMLConfigurationError: File
> > > "/Zope3/lib/python/psycopgda/configure.zcml", line 6.2
> > >    ImportError: No module named psycopg
> >
> > You obvioulsy need to install psycopg (I'm guessting version 1.x). 
It's
> > a standard Python package that lets Python software interface with the
> > PostgreSQL database. psycopgda needs it.
> >
> > Your Linux distribution most probably has psycopg. If you're on Mac OS
> > X, get darwinports, fink or something similar. They should all have it
> > (I know darwinports does).
> >
> > Philipp
> >
> > _______________________________________________
> > Zope3-users mailing list
> > Zope3-users@zope.org
> > http://mail.zope.org/mailman/listinfo/zope3-users
> >
> _______________________________________________
> Zope3-users mailing list
> Zope3-users@zope.org
> http://mail.zope.org/mailman/listinfo/zope3-users

_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to