Hey guys.

I have a problem with my Zope3 installation on a kubuntu edgy system. I installed the current zope3 package (zope 3.2.2) with aptitude. Starting a zope3 instance is working, but if I want to add a file, an image or a self-made content object with the ZMI, I get a Traceback like it's reported here [1]

I tried to apply the patch [2] I found, but that failed. I then tried to apply it manually by just modifying the two affected lines.
old: def readline(self):
old:     data = self.stream.readline()
new: def readline(self, size=None):
new:     data = self.stream.readline(size)
That's what I deduced from [1] and [2].

After that the traceback changed a little bit, but adding the objects still fails with the following output:
2007-01-03T18:46:37 ERROR SiteError http://localhost:9673
Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/zope/publisher/publish.py", line 131, in publish
File "/usr/lib/python2.4/site-packages/zope/publisher/browser.py", line 255, in processInputs
    fs = FieldStorage(fp=fp, environ=self._environ, keep_blank_values=1)
  File "cgi.py", line 530, in __init__
    self.read_multi(environ, keep_blank_values, strict_parsing)
  File "cgi.py", line 650, in read_multi
    environ, keep_blank_values, strict_parsing)
  File "cgi.py", line 532, in __init__
  File "cgi.py", line 665, in read_single
  File "cgi.py", line 687, in read_lines
  File "cgi.py", line 715, in read_lines_to_outerboundary
    line = self.fp.readline(1<<16)
File "/usr/lib/zope3/lib/python/zope/publisher/http.py", line 205, in readline
    data = self.stream.readline(size)
TypeError: readline() takes exactly 1 argument (2 given)

As you can see, the traceback is pretty similar to the one before I changed those two lines. I don't really know, what to do because I don't deem myself able to fix that on my own by changing the affected python code.

Does anone know that problem or has a clue what to do? I would appreciate every hint.

Thanks in advance,


[1] http://www.zope.org/Collectors/Zope3-dev/535 (bottom of the page)
[2] http://lists.alioth.debian.org/pipermail/pkg-zope-commits/2006-October/000342.html
Zope3-users mailing list

Reply via email to