Stephan Richter wrote:
class Application(Contained, Persistent): ... @apply def stati(): """See IApplication""" def getStati(self): return self._stati def setStati(self, value): removed = set(self._stati) - set(value) added = set(value) - set(self._stati) self._stati = tuple(value) for item in removed: zope.event.notify(StatusRemovedEvent(self, item)) for item in added: zope.event.notify(StatusAddedEvent(self, item)) return property(getStati, setStati)
Apart from the quite confusing spelling of this property (I suggest something like http://cheeseshop.python.org/pypi/rwproperty for better readability), I just wanted to point out that "stati" is an incorrect Latin plural for "status". The plural is simply "status" (the "u" being long in the plural, as opposed to being short in the singular). But as far as I know, the only accepted plural form in English is "statuses".
-- http://worldcookery.com -- Professional Zope documentation and training _______________________________________________ Zope3-users mailing list Zope3firstname.lastname@example.org http://mail.zope.org/mailman/listinfo/zope3-users