On Sunday 27 May 2007 18:55, Vinny wrote:
> I did try the above, but it complained about needing a
> newer setuptools than I had.  No big deal, I can update
> that easily enough.

This is really strange. I thought that bootstrap.py would install the version 
of setuptools that is needed, but other people know more about setuptools and 
buildout to give better advice. Anyone?

> Before I go further though, does the above command set
> install a full version of zope and if so, what version?
> Do I need 3.4.0a1 to run this demo or can I use 3.3.0
> or 3.3.1?  I'm running 3.3.0 but can upgrade to 3.3.1.

You will not need anything. Buildout will pull down all the eggs you need for 
you and install it in a local eggs directory, not effecting your global 
Python install at all! The z3c.form* packages do work with Zope 3.3.0 or Zope 
3.4.0b1. I just checked in and released a compatibility module for z3c.form.

> > Installation
> > ------------
> >
> > All packages have been released in source and binary-egg format on PyPI
> > and ``download.zope.org/distribution``. You can use setuptools to install
> > them. Here is a list of all packages:
> >
> > * z3c.form
> > * z3c.formui
> > * z3c.formdemo
> > * jquery.javascript
> > * jquery.layer
> > * jquery.widget
> So, perhaps I can install those packages (in instance/lib/python)
> and I should be good to go?

That would be one way to go. Of course you also need to isntall the ZCML 
slugs. However, the 5 steps to run the demo will do everything for you to get 
the demo to run.

Stephan Richter
CBU Physics & Chemistry (B.S.) / Tufts Physics (Ph.D. student)
Web2k - Web Software Design, Development and Training
Zope3-users mailing list

Reply via email to