My office's migration to eggs and the like is going slowly (too much
other work to do). However, I'm trying to do new work in the 'right'
way and use eggs and buildouts for making small reusable packages. I
did such a package yesterday and it works like a champ on its own:
buildout can get everything it needs to run the tests, the tests have
100% coverage (yay!), etc.

But now I'd like to be able to install that into "classic" zope 3.3
instance homes, trying to be as unobtrusive as possible.

I tried using '' and it looked like a decent
solution...for a moment. However, when I try to install my component
it then starts trying to install the dependencies. Even when I specify
'--no-deps' to easy_install.

Since the Zope 3.3 installation satisfies most of my component's
dependencies, I don't want it fetching everything else. But I do want
it to get those pieces for testing, etc. I've worried about this issue
for a while -- how to get setuptools to ignore dependencies that are
satisfied by some big installation like Zope 3.3.

In my, should I move all of my 'install_requires' bits that
are satisfied by a regular Zope installation into an 'extras_require'?

Jeff Shell
Zope3-users mailing list

Reply via email to