Hi,

I am trying to install DocumentLibrary 1.2b2 from
http://www.infrae.com/products/documentlibrary

My system has Python 2.4 and is running Debian.  The box I am attempting
to install it on does not now, nor has it ever, had any Zope components.

DocumentLibrary is shipped using the buildout system.  I have run the
buildout script, but when I run parts/instance/bin/zopectl start, Zope
dies almost instantly.

Under parts/instance/log/transcript.log, I find a traceback, which ends
with:

  File
  
"/home/jgoerzen/no-backup/programs/DocumentLibrary-1.2b2/eggs/tmpwHsFrh/zope.configuration-3.4.0b1-py2.4.egg/zope/configuration/config.py",
  line 485, in factory
  zope.configuration.xmlconfig.ZopeXMLConfigurationError: File
  
"/home/jgoerzen/no-backup/programs/DocumentLibrary-1.2b2/parts/instance/etc/site.zcml",
  line 5.2-5.32
      ZopeXMLConfigurationError: File
      
"/home/jgoerzen/no-backup/programs/DocumentLibrary-1.2b2/parts/zope3/src/zope/app/configure.zcml",
      line 68.2-68.42
          ZopeXMLConfigurationError: File
          
"/home/jgoerzen/no-backup/programs/DocumentLibrary-1.2b2/parts/zope3/src/zope/app/rotterdam/configure.zcml",
          line 6.2
              ConfigurationError: ('Unknown directive',
              u'http://namespaces.zope.org/browser', u'layer')

Does anyone have any idea how to fix this?

Line 6 of that file begins this tag:

  <browser:layer
      name="rotterdam"
      interface="zope.app.rotterdam.rotterdam"
      bbb_aware="true"
      />

Thanks,

-- John
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to