On Sep 10, 2008, at 5:01 PM, Santiago Videla wrote:

> Hi Gary
> thanks for the help
> That's a shame.  Could it be that, if you specify a version of  
> zope.testing in your setup.py that is equivalent to the version of  
> zope.testing in your Plone app, the overwriting happens but without  
> ill effects?  I bet that would work.
> I will have to this with all the packages that zc.async requires,  
> right?
> zope.component
> zope.interface
> zope.testing
> ...
> and so on

Well, for a stable production, I believe you'll want to specify all of  
those, yeah.

For your specific problem here, it's less clear.  For a first cut, I'd  
probably aim for the minimum changes that you discover you need, but  
yeah, another approach would be to specify all of the packages that  

I don't know which approach will be faster.

> what I don't know is where I can find what versions for each egg  
> should I use. Latest plone use Zope.2.10.6. is there any place where  
> I can see the versions?
> I found this: 
> http://svn.zope.org/Zope2.buildout/trunk/versions-zope3.cfg?rev=90415&view=markup
> but I'm not sure if it's correct
> http://www.zope.org/Products/Zope/2.10.6/Zope-2.10.6-released
>       • Zope 3.3, Five 1.5 integration
>       • replaced several Zope 2 modules with their sister implementation  
> of Zope 3
> I guess that I have to specify all the versions that Zope3.3 uses

Zope 3.3 was not eggified.

Looking on pypi (http://pypi.python.org/simple/zope.testing) it looks  
like you can try the 3.6 line, the 3.5 line, the 3.4 line or the 3.0  

If you don't get success soon, let me know what the exact traceback  
you get is, and under what exact circumstance (running your own tests,  
right?).  I might be able to suggest a specific zope.testing version.

I suspect this won't be as easy as I would like until Zope 2/Plone is  
eggified. :-/ That said, having to specify versions wouldn't be too  
bad, once the version cocktail has been determined.

> Not at the moment.  I have been following the ZC opinion--brought  
> about by pain, not theory, BTW--that test dependencies should be  
> included as primary dependencies.
> However, your story seems like a reason to divide up the  
> requirements, especially if my first suggestion doesn't work for  
> you.  Maybe I'll do that for the next release (1.5.0) which I hope/ 
> intend to make in the next 7 days.
> don't worry, others packages requires zope.testing as well
> * ZODB
> * zc.twist

I hear you.  FWIW, I can help with zc.twist if you want, but I doubt  
ZODB is going to change.


Zope3-users mailing list

Reply via email to