Hermann Himmelbauer wrote:
> Am Mittwoch 15 Oktober 2008 16:46:06 schrieb Hermann Himmelbauer:
>> Hi,
>> It seems that buildout is broken:
>> A "bin/buildout" fetched some new packages, especially:
>> zope.app.component-3.5.0
>> The previous version was:
>> zope.app.component-3.4.1
>> The problem is, that a file, called "back35" is missing in
>> zope.app.component-3.5.0 which is, however, imported/needed in several
>> other files, e.g. in zope.app.form.browser.metadirectives.py:
>> from zope.app.component.back35 import LayerField
> Hmmm, just tried a fresh buildout again, now I get this:
> src/zope/app/container/_zope_proxy_proxy.c:746: warning: initialization from 
> incompatible pointer type
> error: Setup script exited with error: command 'gcc' failed with exit status 1
> An error occured when trying to install zope.app.container 3.6.1.Look above 
> this message for any errors thatwere output by easy_install.
> While:
>   Installing app.
>   Getting distribution for 'zope.app.container'.
> Error: Couldn't install: zope.app.container 3.6.1
> What's happening here? Is somebody updating the packages?

zope.app.container 3.6.1 has been released for a long time already. 
However, the C code hasn't been updated to Python 2.5 yet (and therefore 
breaks on 64bit systems). Bugfix releases for zope.app.container 3.5.x 
have long been available and you should've used one of those. However, 
I've now made another bugfix release of zope.app.container 3.6.x as well 
which contains the necessary fixes to the C code.

> Is there perhaps a way to switch to an older release that works?

Sure. Pin your versions, e.g. to the KGS.

Zope3-users mailing list

Reply via email to