On Wed, Dec 17, 2008 at 4:04 AM, Nylan <ny...@gmx.net> wrote:
> As mentioned here too:
> https://bugs.launchpad.net/zope3/+bug/303721
> After the buildout, starting zope gives me the error:
> --------------------------------------------------------
> zope.configuration.config.ConfigurationExecutionError:
> zope.configuration.exceptions.ConfigurationError: Help Topic definition
> Project/eggs/transaction-1.0a1-py2.4.egg/transaction/README.txt does not exist
> --------------------------------------------------------
> transaction 1.0a1-py2.4
> zope.app.apidoc 3.4.5-py2.4
> Is this a bug or do i miss something in my buildout.cfg?

It looks like the transaction documentation has been moved around and
zope.app.apidoc hasn't been updated.  You could remove apidoc from your
project altogether or just the "book" by adding an exclusion like so:

  <include package="zc.configuration" file="meta.zcml"/>
  <exclude package="zope.app.apidoc.bookmodule" file="book.zcml"/>

The above has to be "early" in your configuration.

Preventing failures like this from popping up is one reason to carefully
control the versions you use in a project.
Benji York
Senior Software Engineer
Zope Corporation
Zope3-users mailing list

Reply via email to