I just worked through Paul Carduner's z3c 'zcontact' tutorial and now 
want to create and manage users. 

If I login as the manager that I created when I ran zopeproject, then I 
see the zmi and can create a pau, either within the top level or under 
++etc++site.  I cannot yet fully configure the pau without an 
authenticator plugin.  So within the pau I create a PrincipalFolder, and 
to that folder I add a Principal.  Now I can configure the pau, 
selecting the Session Credentials utility and the PrincipalFolder I just 
created and hit the Change button.  From a different browser, I attempt 
to login as the Principal I created but am immediately prompted again 
for username and password. 

Philipp's chapter 22 says that if the pau is at the level of the login 
attempt, and the principal is granted the needed role, the login should 
succeed.  So I select the PrincipalFolder and go to the Grant screen to 
search for the principal's username, or the principal folder's name, but 
neither is found.  Nor can I find 'member'.  I can find only 'manager', 
so, while the principal folder is selected, I grant it every role and 
permission, but still the new principal cannot login.

What am I missing?  Is there something I should have read to avoid this 


Zope3-users mailing list

Reply via email to