>>I just installed release 2.2.0a1 on a glibc Linux box, but I keep
>>getting a permission problem when accessing a database query.
>I have encountered the same problem using ZOracleDA
>under SPARC Solaris.

>    File /data/www/Zope/Zope-2.2.0a1-src/lib/python/DocumentTemplate/DT_In.py,
> line 602, in renderwb
>      (Object: jis_query)
>  Unauthorized: 0      

I've been especially frustrated by this.  I just brought
up Zope 2.2.0a1 because we have a few projects that need
to be developed and I want them all using Zope.  I don't
want to have a lot of conversion pain going from 2.1.6,
so I took a chance on using alpha software in this
environment.  I know the risks.  That doesn't make this 
any less painful.

I often tell our students that one of the best features
of Open Source software is that if there's an error, it
can be fixed (by the user or by a helper of the user's
choosing) without waiting on the company who controls
the source.  I'm just starting to learn Python, so I
didn't feel like I was up to the task of doing anything
usful in this case.

I was wrong.

After beating on this over the last day or so trying to
understand what was happening at the Web interface level
(thinking that I must have just screwed up a permissions
setting somewhere), I finally looked at the code and
simply commented out line 602 in

        # raise ValidationError, index

Ta da!  It works...for now.  This little patch will get
me up and going.  I trust that someone will fix whatever
problem necessitated this in a future release and I
won't need this awful kludge, but it sure is nice to be
able to use it now.


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to