Folks -

I'm now finding some interesting behavior with the ZODBC connection.

I set up a connection and had no problems with it (requires DSN id password).

I went back to it at a later point in time and it no longer worked. What changed?

I'm running ZOPE 2.1.6 on NT4 sp4. I started out running ZOPE from the start.bat file.

type start.bat
"c:\zope\ZopeDIR\bin\python.exe" "c:\zope\ZopeDIR\" -D -w 80 -a

If I start ZOPE from the start.bat file, the ODBC connection works flawlessly (with my 
minor testing)

If I start ZOPE as a service 
(HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ZopeDIR\Parameters = 
"c:\zope\ZopeDIR\bin\python.exe" "c:\zope\ZopeDIR\" -S -D -w 80 -a

and then attempt to open the ODBC connection, I receive the following error

Invalid connection string: DSN id password (changed for obvious reasons)

Traceback (innermost last):
  File c:\zope\ZopeDIR\lib\python\ZPublisher\, line 214, in publish_module
  File c:\zope\ZopeDIR\lib\python\ZPublisher\, line 179, in publish
  File c:\zope\ZopeDIR\lib\python\Zope\, line 202, in 
    (Object: RoleManager)
  File c:\zope\ZopeDIR\lib\python\ZPublisher\, line 165, in publish
  File c:\zope\ZopeDIR\lib\python\ZPublisher\, line 160, in mapply
    (Object: manage_open_connection)
  File c:\zope\ZopeDIR\lib\python\ZPublisher\, line 102, in call_object
    (Object: manage_open_connection)
  File c:\zope\ZopeDIR\lib\python\Shared\DC\ZRDB\, line 209, in 
    (Object: RoleManager)
  File c:\zope\ZopeDIR\lib\python\Shared\DC\ZRDB\, line 227, in connect
    (Object: RoleManager)
  File c:\zope\ZopeDIR\lib\python\Products\ZODBCDA\, line 155, in __init__
BadRequest: (see above)

Has anyone experienced this before? Any thoughts? I much prefer running Zope as a 
service, but...


- Steve

Get your Private, Anti-Spam, Free Email at 
and Step into a Friendly Universe!

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to