On Fri, 26 May 2000, Graham Chiu wrote:
> Many of these variables cause problems for those starting out with Zope.
> Why not create alternate names such as sequence_* and degrade the
> former?

yeh, i suggested something like this some time ago.  Perhaps we should make a 
bit more noise.

Agreed, I have a fair bit of legacy code using sequence-*, but if the CHANGES 
mentioned this would break, that would be fair.  In fact, wouldn't sequence_* 
be faster than _['sequence-*'] anway?

A deprecation over the next few versions could be fairly easily handled. 
(Assuming, of course, people actually READ the changes file :)

> - --
> Regards,  Graham Chiu
> gchiu<at>compkarori.co.nz
> http://www.compkarori.co.nz/index.php
> Powered by Interbase and Zope

Have a better one,

<dtml-var standard_work_disclaimer>

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to