I just installed Zope 2.2.0a1 and when I tried to add the Zope tutorial
product I got the following error:

The database connection connection cannot be found. 

Here is the traceback from the source:

 The database connection <em>connection</em> cannot be found.
Traceback (innermost last):
  File /home/local/Zope/lib/python/ZPublisher/Publish.py, line 224, in publish_module
  File /home/local/Zope/lib/python/ZPublisher/Publish.py, line 189, in publish
  File /home/local/Zope/lib/python/Zope/__init__.py, line 221, in 
  File /home/local/Zope/lib/python/ZPublisher/Publish.py, line 175, in publish
  File /home/local/Zope/lib/python/ZPublisher/mapply.py, line 160, in mapply
    (Object: addTutorial)
  File /home/local/Zope/lib/python/ZPublisher/Publish.py, line 112, in call_object
    (Object: addTutorial)
  File /home/local/Zope/lib/python/Products/ZopeTutorial/TutorialTopic.py, line 194, 
in addTutorial
  File /home/local/Zope/lib/python/OFS/DTMLMethod.py, line 160, in __call__
    (Object: setup)
  File /home/local/Zope/lib/python/DocumentTemplate/DT_String.py, line 500, in __call__
    (Object: setup)
  File /home/local/Zope/lib/python/DocumentTemplate/DT_In.py, line 691, in renderwob
    (Object: sample_data)
  File /home/local/Zope/lib/python/DocumentTemplate/DT_Util.py, line 333, in eval
    (Object: insert(_.getitem('sequence-item')))
    (Info: insert)
  File <string>, line 0, in ?
  File /home/local/Zope/lib/python/Shared/DC/ZRDB/DA.py, line 412, in __call__
    (Object: insert)
AttributeError: (see above)

If it makes any difference, I am using a Data.fs that I copied in from a
1.1.2 install. I tried to add several other product and they were all

Harry Henry Gebel, Senior Developer, Landon House SBS
West Dover Hundred, Delaware

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to