>>> Justin Sheehy wrote
> Hello,
> I am trying to build the DCOracle module and having trouble right off
> the bat.  I have tried both 1.3.0 and 1.3.1 b1 with the same results.
> The file src/oci_8.c does an #include "oci.h", but I don't seem to
> have a file named oci.h in my oracle install:

It normally lives in rdbms/demo/oci.h

Under some Oracle installation modes, rdbms/ is only accessible to 
user 'oracle'. I'm not sure what options you'll need to specify to
get that particular directory installed. (if someone was to destroy 
the oracle installer and replace it with something that worked, I 
think a lot of people would be very very happy.)

On a related note - make sure you link with libclntsh, not libnjni8 -
at least one version of a Setup file for DCOracle specified njni8.
As far as we can tell, libnjni8 is not properly threadsafe on solaris/


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to