Since I installed Squishdot 0.4.0 (yesterday) on Zope 2.1.6 (under Red Hat 
Linux) I've been getting KeyErrors when clicking on an article's topic 
image, which uses an URL like this:

http://myserver/Zope/testsquish/search?subject=Squishdot&op=articles

In Squishdot 0.3.2, the errors didn't occur.

I applied the fixes mentioned by Michel Pelletier in his (Zope-dev] message 
("The Mysterious Key Error and Unrelated Searc Result Bug"), and updated 
the ZCatalog. This didn't fix the problem.

Here is the stack trace:

Traceback (innermost last):
   File /data/Zope-2.1.6/lib/python/ZPublisher/Publish.py, line 214, in 
publish_module
   File /data/Zope-2.1.6/lib/python/ZPublisher/Publish.py, line 179, in publish
   File /data/Zope-2.1.6/lib/python/Zope/__init__.py, line 202, in 
zpublisher_exception_hook
     (Object: ElementWithAttributes)
   File /data/Zope-2.1.6/lib/python/ZPublisher/Publish.py, line 165, in publish
   File /data/Zope-2.1.6/lib/python/ZPublisher/mapply.py, line 160, in mapply
     (Object: search)
   File /data/Zope-2.1.6/lib/python/ZPublisher/Publish.py, line 102, in 
call_object
     (Object: search)
   File /data/Zope-2.1.6/lib/python/Products/Squishdot/Squishdot.py, line 
954, in search
     (Object: ElementWithAttributes)
   File /data/Zope-2.1.6/lib/python/ZPublisher/HTTPRequest.py, line 760, in 
__getitem__
KeyError: (see above)


Does anyone have any ideas on how to fix this?

Thanks.

David Trudgett





_______________________________________________
Zope maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to