Hi All,
I hope someone can help, I'm about to tear my hair out and toss my PC out
of the window. I am basically trying to make my own Image class, by copying
the one in OFS and renaming a few bits and bobs. In a frenzy of broken
products, I copied one of the supporting classes from OFS to my new dir
OffS (original huh?) quickly realizing I should just change the code. Thus:

*Copy PropertyManager.py from OFS to OffS (my new dir).
*Restart Zope
*Get an error (Can't find ZDOM)
*Oh didn't want to do that, delete PropertyManager.py from OffS
*Change my OffImage.py - from OFS.PropertyManager import PropertyManager
*Restart Zope
*Same Broken product, Same error

Traceback (innermost last):
  File "/usr/local/Zope-2.1.6-linux2-x86/lib/python/OFS/Application.py",
line 387, in import_products
    product=__import__(pname, global_dict, global_dict, silly)
  File "/usr/local/Zope-2.1.6-linux2-x86/lib/python/Products
/OffSP/__init__.py", line 5, in ?
    import OffS.OffImage #, OFS.Folder, AccessControl.User
  File "/usr/local/Zope-2.1.6-linux2-x86/lib/python/OffS/OffImage.py", line
8, in ?
    from PropertyManager import PropertyManager
  File "/usr/local/Zope-2.1.6-linux2-x86/lib/python/OffS/
PropertyManager.py", line 90, in ?
    import ZDOM
ImportError: No module named ZDOM

*Ok, I thought, Netscrape must be caching the page, clear all the cached
*Same problem
*Ok Netscrape, I'll use lynx instead
*Same problem

*Now going RRM (Random Resolution Mode) and getting nowhere. Checked the
code for the Umphteenth time, it is definitely not the piece of code in the
error message
*Tried deleting PYC etc, but still no joy!
*Waaah Boo hoo, It's beating me

I'm about to delete every PYC in the Zope dir see what happens, Can anyone

>From the stuck-in-a-room-with-doors-and-windows dept

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to